Sketch App running poorly

Is Sketch App running poorly only for me? It keeps lagging, freezing, and copying things slower. Restarting doesn’t help.

It’s been happening since yesterday. Could it be related to the AWS outage?

Running on M1 chip, Sonoma 14.1.1.

1 Like

This has been an issue for me as well. I keep everything very clean and use minimum of plugins and it all runs on M1 Max whcih should be able to handle these files well. I have a file that is around 450MB and does have a bunch of big images, but still doesn’t feel like something that it should lag and should be able to run smoothly on such a configuration. I had this problem I think since v95.

To me it happens with moving symbols around, using color picker, copying images around and trying to click through groups. I also have an issue which I reported weeks ago that freezes Sketch when duplicating or moving symbols on symbols page. It all seems a bit related, there seem to be some issues.

1 Like

And the prototypes aren’t rendering properly either. Often freezing on a black screen or failing to update the content, requiring multiple attempts. Sometimes even fixed position elements are missing from it…

Hey there!

Thank you both for raising these issues. We truly appreciate you taking the time to share the tidbits with us and we’ll make sure these are handled properly.

Would you both mind:

  • Writing to us at productsupport@sketch.com
  • Share with us the Document or Document URL where the issue happens
  • Also give us as much context as possible? These might be things our team is actively working on and we’d like to make sure to share them with the appropriate team.

Thank you both in advance! :pray:

Sure, just sent them

1 Like

Reported.

1 Like

Thank you both!

My colleagues picked up these reports right away and they’ll reaching out asap!

:+1:

I’m also experiencing this. Submitted a bug. Has anyone who previously reported this heard back? This is preventing me from working at the moment so critical for me.

1 Like

The support pinged me with a troubleshoot solution (restart, safe mode, reinstall)
I tried the safe mode, but not much changed. Also removed the plugins, I don’t really need. It’s better now, but not that smooth as used to be. But still fine to work with on my end.

Hi @Beegee and @ollie

Sorry to hear about these performance issues. This topic is quite nuanced. It can involve many different things from hardware to plugins and the main one: document contents and structure.

If the common causes like the one’s you received Gabor don’t show significant improvements, the best option is to take a close look at the affected files, since file content and structure are likely a major factor here.

We’d love to help – if you haven’t already done so – would you mind sharing a copy of your affected documents to our support email productsupport@sketch.com?

Many thanks in advance and we’re looking forward to troubleshooting this for you

Cheers,

2 Likes