Show/hide layout doesn't work when you zoom out to <25%

On the mac app, when you zoom out to <25% show/hide layout functionality stops working for an artboard.
Judging from the specific number when it happens, I’d assume that this is a behaviour that has been done on purpose, but I just can’t understand the benefit of such limitation.
Or is it just related to the fact that the layout stops showing at 25% zoom?

Hi there,

Yep, that’s correct. Show/Hide Layout stops working at that zoom level because it’s hidden by default at that level too, so there’s no need to toggle it, since it will always be hidden to help see the contents of the artboard without the bars from the layout columns

1 Like

Well, the problem is that there is need to toggle at 25% even if you can’t see the layout at that zoom level - when you toggle on several desktop artboards which won’t fit in 25% zoom.
You zoom out to select the artboards, the show/hide option disappears, but when you zoom in again, the option still isn’t active, to make it work you need to deselect the artboard and select it again.

Hey, thanks for this update!

You’re right! The button doesn’t become active again when you zoom in again. I’ve shared this one with the team so they can look into it, and the good thing is that there is a workaround: the ⌃L shortcut keeps working when you zoom in again.

So you can use these shortcuts to show and hide Layout and it’ll always work:

  • ⇧⌘A to select all artboards
  • ⌃L to show/hide the Layout columns

Here’s a video, I hope it’s useful:

1 Like

Works indeed! Thank you, that’ll keep me rolling for the time being.
Special thanks for the select all artboards shortcut, didn’t know this one, very handy in my case :+1:

1 Like

Happy to help! Let us know if you have any other question or feedback about Sketch :raised_hands: