Quirk with rendering some SF Symbols

In Sketch for Mac, some SF Symbols render different from how they render in the SF Symbols app.

After an hour-plus of trying to diagnose the issue, I discovered that, in some (very specific?) cases, Sketch will render SF Symbols set in SF Pro different from those set in SF Pro Text and/or SF Pro Display. In this particular case it’s chevron.up.chevron.down. A byproduct of this is that Pop-up buttons render incorrectly in every symbol instance from Apple’s Library.

I’m not sure if this is intentional or not. If it is, I’d love to know why. It’s certainly confusing. In the SF Symbols app and Figma, symbols (including chevron.up.chevron.down) render the same way regardless of what typeface is selected. I understand rendering (and everything to do with) fonts is more complicated than it seems. If someone could enlighten me that would be great.

I should note that I believe chevron.up.chevron.down has been modified in subsequent versions of SF Symbols, from the original, short and stout version, to the current, long and lean version. I’m not sure if this plays in to it, but considering this is the first-and-only SF Symbol I’ve seen with this issue, I’m thinking it might?

Hey Jordan, :wave:

Thanks for flagging this issue for us. We’ve got our team on it, diving into the nitty-gritty to figure out what’s going on. Expect an update from us soon as we unravel the mystery.

By the way, we noticed your contact form in productsupport@sketch.com. Rest assured, we’ll shoot you an update through that channel as well.

Cheers, :pray:

Hey @jordanborth :wave:

Following up on this:

The font discrepancy issue occurs when an enabled library has embedded an older version of the SF font, causing Sketch to prioritize the older version over the Symbols app’s font version.

Since the SF font frequently receives updates, we recommend locating the affected library and un-embed the font.

  1. Open the affected library
  2. Access Document Settings (⇧⌘,)
  3. Navigate to the “Embed Fonts” tab
  4. Disable all SF fonts

Locating the exact library can be challenging, but here’s a quick workaround, though it may not be ideal in all cases:

  1. Disable all libraries - in the Sketch settings and Document Settings (of the affected document)
  2. Quit and Relaunch Sketch
  3. Open the Affected Document
  4. Drag the Symbol Again

These steps should ensure Sketch reads the correct version of symbols and resolve font discrepancies caused by conflicting library(ies).

Let us know if this helps.

Cheers :pray: