Embedded fonts not rendering on Sketchcloud

Hi. Recently created a new doc, using the usual library I use for everything for some elements, but the font I always use isn’t rendering correctly in Sketchcloud – defaulting to Helvetica.

Every other doc that uses the same font and libraries I view in Sketch Cloud is fine, and I’m using nothing different. I’ve selected the embed options from the doc settings pane (they were already checked, and in the Library file itself) but seeing no difference in that one particular file.

Any ideas? Only differing factor seems to be that this doc is shared with external contributors to view on Sketch Cloud, but I’m not sure that would make any difference. Help!


This is happening to my team as well.

We have some fonts embedded in our library files that are used in symbols. When we pull these library symbols in another document and view them in the Sketch web app, the font appears to be Helvetica. We’ve checked the fonts section of document settings on both the library and the working document.

We’re experiencing this whether this doc is shared with external contributors or not.

Does it make any difference if you make sure your Library file is set to ‘public’? In Sketch app, open library, select ‘Share’ from your avatar menu to set that. I discovered this as an aside to troubleshooting the font problem! (the symbols in the library may contain a font that’s not crossing over to the cloud?)

For the font issue, I ended up copying all the artboards into a new file, saving to workspace, and I’m now seeing the fonts correctly on sketchcloud (still not in the original file). :man_shrugging:t2: I tried it with one artboard first to check and it worked.

Hey @Burnhameister and @drwiley05 I’m sorry to hear you’re both experiencing this issue.

I’ve tried to reproduce this rendering issue but it seems I’m not able to. Our customer support is more than happy to help you out, but they need a few more details.

Would you mind sharing this issue via the customer support form? And:

  • include more details regarding the type of font
  • add a link to the document or another way to share the document with us

We can keep this topic open to inform others about the outcome of the enquiry.

Hi there,

Same issue here. The custom font is embedded in the document as well as the library, but the rendering remains Helvetica. Did you find a remediation? The workaround mentioned above is not an option for me unfortunately. I would prefer not pasting my library files elsewhere nor create instances of it.

To the moderator (the link won’t work to the public), here is the Sketch Link where you can see the issue. Similar problems occur for the input field. The rendering on file is good, but on web it’s glitched.

Hey @Adrien - After reading these cases, we’ve discussed this internally. We suspect something might be happening with the embedding options on the Mac app.

Could you uncheck the option to embed those fonts, save, then check and save again? The process should be as follows:

  1. Open the document on your Mac.
  2. Go to File>Document Settings.
  3. On the Embed Fonts tab, deselect all fonts.
  4. Save and wait for the green light to confirm it’s saved.
  5. Select the fonts to embed again, then save.

(I know this sounds like basic troubleshooting, but we recall similar cases solved this way.)

If the issue persists, could you write to us at productsupport@sketch.com, attaching any affected font and the link to the document so we can try to reproduce the issue?

Same for @Burnhameister and @drwiley05 - If you are still affected by this, could you try these steps and write to us if that doesn’t solve the issue? Let’s see if we can narrow this down! :mag_right:

@jonne @JorgeF
A month ago we had the same issues in our Template document which we uploaded to Sketch Cloud :thinking:
Decided to upload as a simple document (not a template) and then saw the correct fonts in Sketch Cloud.

Thanks @vitlayozza. I think that’d be a nice thing to try if the affected users are managing templates.

In addition, we’d like to test it as well, in case it’s an isolated case related only to templates. Could you write to the mentioned email (productsupport@sketch.com) attaching a local copy of the affected document, so we can try to reproduce it?

We’ll try to reproduce this and see if we can spot some unforeseen issues.

@JorgeF Yep, This is our .sketch document with templates which we have updated on our Sketch Cloud.

Table Templates.sketch (687.8 KB)

Hello Vitaly! I see that this document has many Libraries and fonts coming from these same Libraries. The plot thickens! :laughing:

So, in this case, could you send the fonts as well? I know the font Poppins is fairly spread and can be obtained elsewhere, but it’s important to test the document with the exact same fonts you’re using just to be sure we’re reproducing the same conditions faithfully.

Since this is a public forum, perhaps you might want to go through the email I mentioned if you prefer to send the fonts or any other detail more privately. Your choice anyway!

@JorgeF we downloaded Poppins from here: Poppins - Google Fonts

1 Like

Hello @vitlayozza. I’ve been trying to reproduce this issue by creating a new upload of that document and fonts in an internal workspace, but no dice. I’ve tried uploading both as a template or a normal document, but I had no luck with either one.

Are you still experiencing this if you turn the document back into a template? If that’s the case, I’d love to take a look at the source of the document. However, for privacy reasons, I would really need you to send that link to productsupport@sketch.com so we can look at it internally.

In case you can’t reproduce this, there’s the (remote) possibility of having one of the Macs uploading a different version of the font. Note that Sketch will upload the font as is embedded in the document, so I suspect that a different version of the font could have been the offender here. Note that fonts can have different versions depending on where these come from, so I would check if all your Editor’s Mac have the exact same version of the font installed, just in case.

I’m curious about this one. It’s a strange when you can’t reproduce a case consistently and it’s always a matter of looking into details.