Shared Library retains previous layer names (partially)

I have an issue from an old shared library of layer styles (used for Brand colors) where layers styles were previously named
BG/BrandColors/brand_name which we shortened to

We now have a combination of both the new layer names and old layer names present when accessing colors via the layer styles menu in the inspector. Note: the “BG/” has been removed from every layer style in the file so there is no reason this should be displayed in the way shown (screenshot)

Library link here

Mac App version 96.3 on OX 11.7.1

Hi Mark. :wave:
Is this Library in your online Workspace?
If so, try clearing the locally-stored cached version of it by quitting Sketch, then deleting the file from:
~/Library/Application Support/com.bohemiancoding.sketch3/Libraries/
Just in case, also check:
~/Library/Application Support/com.bohemiancoding.sketch3/CloudDocuments/
Then re-launch Sketch and check again to see if the document structure is now correct.

Hey Brett, Thank you for helping. I will try this in the next few minutes or so and report back.

1 Like

File is present in both “Libraries” folder and the “CloudDocuments” folder in the file paths you shared.
*in the “CloudDocuments” it is found under a subfolder.

Should i retain a copy prior to deleting or will the file persist on sketch cloud?

and yes all libraries are stored in sketch cloud in my business workspace.

If the file is saved to your online Workspace (the Cloud), then that’s the original source of truth, and there’s no need to back up what’s stored in the temporary cached local storage. :+1:

File deleted from both locations.
Restarted sketch and the problem persists.

And, it gets a little strange! The library is showing in settings > libraries panel inside the Sketch app. It is not enabled but shows as an option in the inspector panel to fill layers.

Also, when i right click to “remove library” is does not remove.

The fact that the Library is still showing as being available in your document might be because, although it’s unchecked off in the General Settings, it might be checked on in the document-specific settings.
Check File > Document Settings to see if it’s enabled there.

The other thing I’m thinking is that you might also need to delete the local-cached file for the other document that you’re pulling these Library Style into?
I would imagine that if you create a brand NEW document, and with the Library checked on, then the Library document structure would show as correct in there.

Ok I will follow these steps and create a new doc also.

Works perfect in a new document. (Hooray !!) How would i correct this for the current document I am in. Where is the cache located for the current working document ?

1 Like

There’s really not other than:

  • The Document Libraries you enable
  • The Libraries enabled on the app Settings.

However, the app might be showing the Library still because there are some elements, from the old Library, still being used. :thinking:

You could use a plugin like Automate Sketch (Plugins > Automate > Library > Replace Library) and check if it loads the previous Library. If it loads it, then this confirms that there might be some elements from the previous Library still being used.

Great to hear! :raised_hands:

It would be in in a folder in the same location as previously:
~/Library/Application Support/com.bohemiancoding.sketch3/CloudDocuments/

1 Like

Ok Thanks Raul, I have Automate Sketch installed. I will try that.

*ps yes i have layer styles in the current document from the problem library.

1 Like

Thanks Brett. I can work around current document issues knowing it has been resolved for future documents. I appreciate your time and effort into helping solve this.