Missing Sketch Libraries


I don’t know when the problem started, but I recently noticed that neither the “Artboard Template Inspiration” nor the “Default Artboard Templates” are available to me when I want to create a new artboard.

These sketch templates are deactivated in the “Libraries” settings. When I try to activate them, I only get the message “Library not found” …

I use Sketch 99.5, but I don’t have this problem in the beta version (also 99.5). The libraries are available and activated there.

What can I do? Can I somehow install the libraries manually?

SKETCH 99.5:


1 Like

I’ve also stumbled across this bug where the default artboard templates libraries became unavailable all of a sudden. Here’s a few notes that might help the Sketch folks with debugging:

  1. I rarely install or uninstall libraries in Sketch, I’d say once or twice a year.
  2. My ~/Application Support/com.bohemiancoding.sketch3/Libraries folder does contain a bunch of “Artboard Template Inspiration-{UUID}.sketch” and “Default Artboard Templates-{UUID}.sketch” files (some of them look like duplicates due to the same file size) so it’s not like the library files were physically wiped out from disk.
  3. I do switch between normal and Beta versions of Sketch pretty often.

@Xhaust here’s what I do in such cases to bring the default templates back:

  1. (optional, as I can’t remember if I ever did this) Delete these 2 libraries via a context menu.
  2. Try to add an artboard to a document. You’ll see the “No Artboard Templates” placeholder in the Inspector. Pressing “Add Default Templates” will download and install both missing libraries.
  3. Alternatively, in case there’s no “No Artboard Templates” placeholder visible (I believe it wasn’t always visible for me in such cases), I recall that the actual template selector popup control was in fact available at the top of the Inspector panel – selecting something in there should also trigger the installation process.

Hey there!

Thanks for the report, and @rodionovd thanks for the extra tips to get this worked out!

You can also install the Libraries directly from the web app:



Thank you both @rodionovd @raulrincon for your help.


How do i install them from there? I just see download and copy link as options.

You can actually have Sketch expose, and then reinstall those from Sketch directly if you wish to!

  • Quit Sketch, and open a new Finder window
  • Press ⇧⌘G (Shift-Command-G)
  • Enter this path: ~/Library/Preferences/com.bohemiancoding.sketch3.plist
  • Move the highlighted file to the Desktop.
  • Open Sketch, and press ⌘, (Command-,) to open the Settings window
  • Switch to Libraries, scroll all the way down and they should appear there for activation.
  • Done!

Let us know if that works!

1 Like

yeah, although i had to go through and update/fix all my settings and re-add all my libraries :slightly_frowning_face:

1 Like