Importing many Icons into a library: SketchIcons-Plugin doesn't work

Hello all,

I have a problem that I can’t solve without a plugin (at least not at the moment).

About 2 years ago, I used the Sketch plugin “SketchIcons” ( ) to integrate all the Fontawesome icons available at the time (we have a Pro account) into one or more Sketch libraries. At that time I imported all icon SVGs with the help of the plugin and it automatically created all icons in 24x24 , 20x20 as well as 16x16 px (according to my presettings) and named them correctly.

In the meantime Fontawesome has extended their icon database accordingly. Many new icons exist, but not in my Sketch library. I wanted to add the new icons today using the plugin.

Now the plugin no longer works. :weary:

Does anyone here have any ideas on how I can approach my project (possibly with a different plugin)? I am at a loss at the moment.

PS: I have also tried older Sketch versions (Sketch 80 and Sketch 81.1). I assume that I was using these when I created these libraries as described above. However, here too the plugin refuses to work.

I thank you in advance for your relevant advice
Christian from Germany

Hey Christian!

Thanks for the heads up on this plugin not working.

Here’s a workaround, using another Plugin called Import SVGs as Artboards.

  • Open Sketch
  • Install the Plugin above (You can drag-n-drop the .sketchplugin file into the Sketch Window and it will install it!)
  • In the menubar: Plugins > Import SVGs as Artboards.
  • This will open up a new Finder window, where you can select all the icons you want to import.
  • Then, the plugin will show you two consecutive windows: one to define the Width and then the Height of the Artboards where these icons will be imported to.
  • Make sure to verify any SVGs imported after the plugin is done.
  • Done!

Let us know if this works!

1 Like

Another workaround…

If you want to keep on using the same plugin (SketchIcons / we know it has a ton of extra features) you can:

  • Go to your /Applications folder

  • Right-click on Sketch, and then click on Get Info

  • In the window that appears, click on Open using Rosetta

  • Now Open Sketch, and try to run the plugin as you normally would.

    • If you get some warnings about some frameworks, you need to go to System Settings > Privacy & Security > Allow these extensions to run.
  • Done!

Now the plugin should work as expected (we just tested it on Sketch 98.2!). Let us know if this helps! :pray:

1 Like

Hey @raulrincon ,

that worked fine (even without error messages). Thanks for the workaround.

Maybe the trick of starting Sketch in “Rosetta mode” to run no longer working plugins is even a workaround for many other plugins.

You regularly read here in the forum that plugins no longer work … for example in the discussion here: Sketch Community Forum

Best thanks from Germany

1 Like