Trim transparent pixels not working for the last few releases

  • macOS Ventura (13.4)
  • To reproduce:
  1. Select an image with a transparent background rectangle that’s bigger than the colored part of an image
  2. Export PNG (other formats too) with “Trim transparent pixels” unchecked
  3. XXXXX. ← no dice; transparent pixels get clipped.

Circle is 20px radius. Transparent square behind it is 49px to a side. The exported PNG will be 20px by 20px :smiling_face_with_tear:

1 Like

Hey Jose :wave:, welcome to the forum! :pray:

Thanks for sharing this with us! This is a known issue with Sketch 96.3 and we have solved it already on Sketch Beta 97, which you can take for a spin here.

Note: Please, carefully read the disclaimer on the beta page before proceeding. As always, we recommend using these builds with copies of your Documents, just in case.

I tested the same steps on both Sketch 96.3 and Beta 97, and the expected behaviour is back on Beta 97 which should solve this!

Let us know if this helps!

Hey Raul.

I am using Sketch for the past few years and this issue still exists and is absolutely annoying. Everything works great if you export symbols from your symbols artboard. It doesn’t trim transparent pixels and it gives you option to do so (checkmark).

If you put your symbol into your design and make it exportable there, it trims your transparent pixels and the checkmark is not available. It is absolutely crucial for developers as in my case they export assets straight from each artboard design.

Please check the attached screenshot: Screenshot 2023-07-03 at 10.48.12

Hey Piotr,

Thank you for the reply and for getting back to us with this!

This is also a known issue within the app, which I can confirm the team is working on a fix for Sketch 98, and we should have a Beta ready soon, for you to test this and give us your feedback!


You can get Sketch Beta 98 now! Let us know how it goes!