Dropping a new image over old one no longer works correctly


I’m on a Mac and recently a seemingly simple step that I use continuously in Sketch no longer works in the same way. I have to replace existing images with new updated ones and I need them to drop in at the exact same dimension of the image being replaced. This used to work perfectly by choosing the image and then dragging and dropping the new image on top of it. Now, using the same method, the new image is scaled significantly smaller than the image I’m replacing. I’ve tried all manner of dropping while holding command, option, control, etc to no avail.

In regards to the images - the new image is the same dimension and filesize as the image (it’s the same image, just retouched).

What am I missing? Is there any way to recover how this used to function?

Hi @Susie211 welcome to the Forum!

I tested this with the latest version (97.2) and it works as expected, I tried with a masked image, image as a fill and a bitmap, all worked as expected. I tested both JPEG and PNG formats. Take a look at this video and let me know if I missed anything:

Yes, this is working perfectly for you! That is precisely how it used to work for me, but is no longer doing that. I checked to make sure I am working in the same version as you and I am also in 97.2.

@Susie211 Have you tried running Sketch in Safe Mode? Quit the Mac app and then launch it again while holding down the Shift key ⇧ . This opens it in Safe Mode and if everything works as expected, a plugin may have been causing the issue.

If the problem persists in Safe Mode would you mind contacting us at productsupport@sketch.com? :pray: