Disable Rounding in Scale Tool

Is there an option to disable rounding of the shadow values when using the scale tool (⌘K)? For example when scaling down a layer to 50%, a shadow radius of 5 rounds to 3. I’d prefer it to be the decimal number 2.5, though. Is there a way to do this?

I’ve already tried placing the shapes in a group and disabled „fit layers and points to pixel bounds,“ but nothing helped.

Btw, borders don’t get rounded to whole numbers, but shadows and inner shadows do.

Hey Alex! Good point, there’s no clear answer to this logic. There’s no option to disable this, but I think it’s an interesting - and possible easy (:crossed_fingers: ) - change for the future.