Cmd bar keyboard shortcuts ctrl+n, ctrl+p

Just upgraded to sketch 100 on macOS and I really want to use the new command bar feature, however I always keep my hands in the default keyboard position and need to be able to navigate the command results list with ctrl+n, ctrl+p which is the system default (used in spotlight and safari url results etc.).

For some reason ctrl+n works, but ctrl+p doesn’t do anything for me, is this a bug, or do I have some other sort of keyboard conflict?

Hey there!

There might be a conflict of shortcuts here, as the ⌘P (Command-P) shortcut is reserved for the Prototype Preview/Player.

What you can do is:

  • Modify (via macOS Keyboard Shortcuts) the Preview Prototype… shortcut
    • Open System Settings
    • Open Keyboard and then click on Keyboard Shortcuts
    • On the sidebar, click on App Shortcuts
    • Use the ( + ) icon to add a new shortcut.

In the new modal that appears, set it up as such:

(You can choose any keyboard shortcut you want)

And then on Sketch’s preferences pick ⌘P to use as the Shortcut for the Command Bar.

(I just tested this and it works without a hitch!)

Hey Raul, thanks for the reply.

I’m talking about navigating up and down the results in the command bar with the Control (^) key and P and N, not invoking the command bar itself.

It’s a common operating system pattern in macOS to use ctrl p/n to move up and down selections in results lists, see Safari URL bar in macOS and Spotlight results.

1 Like

OH dang, my bad. I totally misread your message then :sweat_smile:

Indeed, these are conflicting Keyboard shortcuts:

  • ⌃P (Control-P) Enables the Pixel grid on Zoom
    • Menu Item: Canvas > Show Pixels on Zoom
  • ⌃N (Control-N) Show/Hides Comments from the Canvas.
    • Comments > Show Comments

You can go ahead and remap these using the guide above, and ⌃P and ⌃N should work as intended. Just tested it after changing the shortcuts above and works without issue!

Let us know how it goes!