Sketch 97.1 Editor bugs

The 97 and 97.1 editor feels buggy and even weird.

  • When I use pen, I have to click VERY CAREFUL to create a point without the handle. Most of the times, it automatically create a handle which has no length. It’s just too sensitive, and make it more complicated to add corner radius to certain anchor points.
  • Using the shortcut T, I can create a text box, or edit an existing one. But now when I use T to edit an existing text box, sometimes it just create a new one. It’s TOTALLY UNPREDICTABLE and driving me crazy.
  • Choosing elements in groups also feels weird. I often need to choose elements and groups within groups through multiple clicks, however the number of clicks it requires seems unstable.

Version: 97.1
System: macOS 13.4
Device: iMac, M1 chip

Hope to see some improvement

1 Like

Hey Sylvan :wave:,

Thank you for sharing this insight with us. In the recent Sketch version, we improved the canvas, which could be linked your report.

→ First Point: This could be linked to the pressure sensitivity of your hardware. It’s worth exploring if adjusting the pressure sensitivity in the system preferences improves the overall behavior. On my side, I tested this situation with versions 97.1, 96.3, and 95.2 and saw no difference between the versions.

→ Second point: I could not reproduce this issue on my side. Steps performed: Press T > click on canvas > type something > exit editing > press T again > click on the text layer > can edit without adding a new text layer. If I Press T > click on canvas → type something > exit editing > press T again > Click on the canvas, this adds a new text layer (which is expected).

→ Third point: We introduce recent alterations (with versions 96 and 97) to the selection process of layers in Sketch. It might be worth considering sharing a video with the steps you perform.

Still, your POV is valid, and it might be a good thing to understand which version you were using before 97 and try to trace back any updates to the behaviors you mentioned in your post. So feel free to share this information.

I hope this can help.
Cheers :pray:

  1. I’m just using apple’s magic mouse and magic trackpad, and pretty sure the sensitivity is well within a normal range, and the problem remains. There are two videos, the first one is v96.3, you can notice that even my cursor moves quite fast, the anchor point has no handle. But the second video shows when I use v97.1, the anchor is in a different state.

  2. It’s not entirely not working, just feel not so stable. In the third video, you can see for the last time I clicked on the existing text box, though my cursor is in the area, it still creates a new box. That’s what confuses me.

  3. Just a feeling too.

The following replies are my videos.

first video

second video

I can’t send the third video, what is happening?

Hey there,

It appears that the forum platform has been hindering the upload of the third video. You may send us the videos at if you are still experiencing the same problem.

Cheers :pray:

1 Like

I tried two emails… neither of them could send it to your email address

This might be a size limitation. Could you upload the video to a cloud service and share the link with us?

Cheers :pray:

Hey Sylvan,

I want to thank you for sharing the videos related to topics 1 and 2. It’s great that you brought up this issue, as we have already identified it as a problem and are actively working on resolving it. As soon as we have a solution, I will be sure to update you

Cheers :pray:

1 Like

Here is the third video: 3 shortcut T 97 1 - YouTube

Hi @SylvanWang :wave:

I’m would like to inform you we’ve just launched the official version with a fix for this issue. If you haven’t already, I highly recommend updating to version 98.

Many thanks for your contribution!

Cheers and happy updating! :rocket:

Thanks for your reply. However I think it’s still too sensitive. Now about 50% anchor points have handles, and it seems not relevant to my cursor movement. Please check it again.

Hi there @SylvanWang , can you try changing your pixel snapping settings in Edit Mode from half pixels to “No pixel snapping”? Snapping to half pixels makes each node more sensitive and can create this unwanted handles. Let us know if this helps!

CleanShot 2023-08-29 at 10.50.16

First, I kinda need the pixel snapping thing… especially when I draw small icons. I need points without handle when I’m using pixel snapping.

Second, the behavior I see is not like what you describe… I tried the no pixel snapping mode, and some of the points still have handles. I know the handles are bugs, because they have no length, and it’s impossible to drag them.

So please check it again, maybe designers in your team can better understand my problem.

In my experience, a physical click on a Magic Mouse often triggers a small movement of the cursor. This acts like a very short click and drag. This used to happen in all the graphic design software I used. For this reason, I switched to a Magic Trackpad a few years ago and enabled the “tap to click” feature. Never had a problem again.

EDIT: I just did some clicking with the Vector tool in Sketch using the Magic Trackpad. With tap-to-clicks: zero curved points. With physical clicks: 2 curved points out of 36.


Hey @SylvanWang :wave:

I recognize your frustration with the behavior you’ve experienced, even after updating to version 98. As of this moment, we haven’t been able to replicate this issue on our end, and it’s not considered a bug. As I mentioned in my initial response, it’s possible that this is related to hardware sensitivity.

Based on feedback from both our community and our internal observations, it seems that the problem may be linked to the sensitivity of the Apple Magic Mouse. Past reports have highlighted similar sensitivity concerns with this hardware.

To investigate further, could you please try using a different mouse (non-apple) or a trackpad (if you have one)? If you notice any differences in behavior between the Magic Mouse and the other peripherical, it would be beneficial for us to understand those distinctions.

We are committed to ensuring that your experience with our software is as seamless as possible, and your feedback is invaluable in helping us address these challenges.

For your reference, we take great pride in involving designers in these cases to gain insights into the pain points of our community and to help us find effective solutions. You can rest assured that we always seek their expertise to understand complex issues like this one.

Cheers :pray:

1 Like

Hi :wave: @tudor

Thank you for your input on this matter. I’m confident that others will find it helpful.

Cheers :pray:

1 Like

I tried magic mouse, magic trackpad, and mx anywhere 3. Though the magic trackpad is the worst, all three devices have some points with handles. I think it still needs improvement, because when I use versions before 96.3, it was never a problem. Older versions only create unwanted handles when my hand makes a noticeable movement, and those handles always have length. Now it feels like random, and it’s impossible to manipulate the zero-length handle.

I think being random and having no length is the key point, that’s why I insist it’s a bug.

I understand that if the mouse moves and clicks at the same time, software may create unwanted handles. And indeed, this situation often comes with magic mouse. But it’s not my case. Sometimes I click very carefully, with trackpad or other regular mouse, but it still create the handles. The key point is that those handles have no length, the line is also not curved , and it’s impossible to manipulate. They only show a little square inside the point circle, and a different point type.